Letter R

ruby-libs - Libraries necessary to run Ruby

Website: http://ruby-lang.org/
License: Ruby or BSD
Vendor: Alcance Libre, Inc.
Description:
This package includes the libruby, necessary to run Ruby.

Packages

ruby-libs-2.0.0.648-35.fc14.al.x86_64 [2.8 MiB] Changelog by Vít Ondruch (2019-04-04):
- Introduce `Gem::UserInteraction#verbose` method as precondition to fix
  CVE-2019-8321.
  * rubygems-2.3.0-refactor-checking-really_verbose.patch
- Fix escape sequence injection vulnerability in verbose.
- Fix escape sequence injection vulnerability in gem owner.
- Fix escape sequence injection vulnerability in API response handling.
- Prohibit arbitrary code execution when installing a malicious gem.
- Fix escape sequence injection vulnerability in errors.
  * ruby-2.4.6-Applied-security-patches-for-RubyGems.patch
  Resolves: rhbz#1699283

Listing created by Repoview-0.6.6-5.fc14.al